Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-10-08 12:07:09 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-10-08 12:07:09 +0200
commit61a6ea38af60b1ffc614ee954725c578b6ebe1aa (patch)
tree5424ca9dbd80b44a05534d2ff5e8bca1d8f7d920 /build-support
parent577a9d43060275d3ca34e011db63e2ee178358bf (diff)
build-support/ruby-bootstrap: building a version not poluting /usr namespace
Diffstat (limited to 'build-support')
-rw-r--r--build-support/ruby-bootstrap/PKGBUILD9
1 files changed, 1 insertions, 8 deletions
diff --git a/build-support/ruby-bootstrap/PKGBUILD b/build-support/ruby-bootstrap/PKGBUILD
index 8c50aec5..d700fa62 100644
--- a/build-support/ruby-bootstrap/PKGBUILD
+++ b/build-support/ruby-bootstrap/PKGBUILD
@@ -44,18 +44,11 @@ package_ruby-bootstrap() {
'ruby-docs: Ruby documentation'
'tk: for Ruby/TK'
)
- provides=('ruby' 'rubygems')
- conflicts=('ruby' 'rubygems')
cd ruby-${pkgver}
make DESTDIR="${pkgdir}" install-nodoc
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}-${pkgver}/LICENSE"
- install -D -m644 BSDL "${pkgdir}/usr/share/licenses/${pkgname}-${pkgver}/BSDL"
-
- # make sure we have binaries in the path
- mkdir -p "${pkgdir}"/usr/bin
- ln -s /opt/"${pkgname}-${pkgver}"/bin/ruby "${pkgdir}"/usr/bin/ruby
- ln -s /opt/"${pkgname}-${pkgver}"/bin/gem "${pkgdir}"/usr/bin/gem
+ install -D -m644 BSDL "${pkgdir}/usr/share/licenses/${pkgname}-${pkgver}/BSDL"
}