Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--build-support/ruby-bootstrap/PKGBUILD9
1 files changed, 1 insertions, 8 deletions
diff --git a/build-support/ruby-bootstrap/PKGBUILD b/build-support/ruby-bootstrap/PKGBUILD
index 8c50aec5..d700fa62 100644
--- a/build-support/ruby-bootstrap/PKGBUILD
+++ b/build-support/ruby-bootstrap/PKGBUILD
@@ -44,18 +44,11 @@ package_ruby-bootstrap() {
'ruby-docs: Ruby documentation'
'tk: for Ruby/TK'
)
- provides=('ruby' 'rubygems')
- conflicts=('ruby' 'rubygems')
cd ruby-${pkgver}
make DESTDIR="${pkgdir}" install-nodoc
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}-${pkgver}/LICENSE"
- install -D -m644 BSDL "${pkgdir}/usr/share/licenses/${pkgname}-${pkgver}/BSDL"
-
- # make sure we have binaries in the path
- mkdir -p "${pkgdir}"/usr/bin
- ln -s /opt/"${pkgname}-${pkgver}"/bin/ruby "${pkgdir}"/usr/bin/ruby
- ln -s /opt/"${pkgname}-${pkgver}"/bin/gem "${pkgdir}"/usr/bin/gem
+ install -D -m644 BSDL "${pkgdir}/usr/share/licenses/${pkgname}-${pkgver}/BSDL"
}