Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support/python-bootstrap
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-05-12 08:23:51 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2023-05-12 08:23:51 +0200
commit4c6f76d856f9787a44e308b7faf3e4ccefcb56be (patch)
tree4b797694e7859336f5969b20c625c6f6609dfadb /build-support/python-bootstrap
parent68a426c2e000489c6ba151ca9af6f0132a1358e3 (diff)
trying to activate the old way of python module bootstrapping
Diffstat (limited to 'build-support/python-bootstrap')
-rw-r--r--build-support/python-bootstrap/PKGBUILD45
1 files changed, 0 insertions, 45 deletions
diff --git a/build-support/python-bootstrap/PKGBUILD b/build-support/python-bootstrap/PKGBUILD
deleted file mode 100644
index 2e42c71c..00000000
--- a/build-support/python-bootstrap/PKGBUILD
+++ /dev/null
@@ -1,45 +0,0 @@
-# Maintainer: Angel Velasquez <angvp@archlinux.org>
-# Maintainer: Felix Yan <felixonmars@archlinux.org>
-# Contributor: Eli Schwartz <eschwartz@archlinux.org>
-
-pkgname=python-bootstrap
-pkgver=3.11
-pkgrel=1
-pkgdesc="Python Bootstrap"
-arch=('any')
-license=('PSF')
-url="https://gitlab.archlinux.org/archlinux/python-bootstrap"
-depends=('python')
-makedepends=('git')
-provides=('python-build' 'python-flit' 'python-flit-core' 'python-installer''python-setuptools' 'python-wheel' 'python-tomli')
-source=("git+https://gitlab.archlinux.org/archlinux/python-bootstrap/#branch=$pkgver")
-sha512sums=('SKIP')
-
-export SETUPTOOLS_INSTALL_WINDOWS_SPECIFIC_FILES=0
-
-prepare() {
- cd "${srcdir}/${pkgname}"
- git submodule init; git submodule update
-}
-
-build() {
- cd "${srcdir}/${pkgname}"
- python -m bootstrap.build
-}
-
-wheels=(
- build-0.9.0-py3-none-any.whl
- flit_core-3.7.1-py3-none-any.whl
- installer-0.5.1-py3-none-any.whl
- pep517-0.13.0-py3-none-any.whl
- setuptools-58.3.0.post20230511-py3-none-any.whl
- tomli-2.0.1-py3-none-any.whl
- wheel-0.37.0-py2.py3-none-any.whl
-)
-
-package() {
- cd "${srcdir}/${pkgname}"
- for wheel in "${wheels[@]}"; do
- python -m bootstrap.install --destdir="$pkgdir" "dist/$wheel"
- done
-}