Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/build-support
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-05-12 08:23:51 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2023-05-12 08:23:51 +0200
commit4c6f76d856f9787a44e308b7faf3e4ccefcb56be (patch)
tree4b797694e7859336f5969b20c625c6f6609dfadb /build-support
parent68a426c2e000489c6ba151ca9af6f0132a1358e3 (diff)
trying to activate the old way of python module bootstrapping
Diffstat (limited to 'build-support')
-rw-r--r--build-support/disabled/python-pip-bootstrap/PKGBUILD26
-rw-r--r--build-support/python-bootstrap/PKGBUILD45
-rw-r--r--build-support/python-pip-bootstrap/PKGBUILD18
-rw-r--r--build-support/python-pip-bootstrap/install.sh (renamed from build-support/disabled/python-pip-bootstrap/install.sh)0
-rw-r--r--build-support/python-pip-bootstrap/install2.sh (renamed from build-support/disabled/python-pip-bootstrap/install2.sh)0
5 files changed, 18 insertions, 71 deletions
diff --git a/build-support/disabled/python-pip-bootstrap/PKGBUILD b/build-support/disabled/python-pip-bootstrap/PKGBUILD
deleted file mode 100644
index 7dc64258..00000000
--- a/build-support/disabled/python-pip-bootstrap/PKGBUILD
+++ /dev/null
@@ -1,26 +0,0 @@
-# Maintainer: Andreas Baumann <mail@andreasbaumann.cc>
-
-pkgname=('python-pip-bootstrap' 'python2-pip-bootstrap')
-pkgver=0.0.1
-pkgrel=1
-pkgdesc="bootstap pip and setuptools for bootstrapping python"
-arch=(i486 'i686' 'x86_64' 'armv6h' 'armv7h')
-url="https://bootstrap.pypa.io/"
-source=("https://bootstrap.pypa.io/get-pip.py")
-sha512sums=('ae0f0b2e41f435d80f955eb577f74fa9561ba283b8c7f65a5dd96270beebf7d2c220d107865e07a31e66d25dd33953cca852100b3f04bf8990626aa69c60fa98')
-
-package_python-pip-bootstrap() {
- depends=('python')
- install=install.sh
-
- mkdir -p "${pkgdir}/usr/bin"
- cp "${srcdir}/get-pip.py" "${pkgdir}/usr/bin/."
-}
-
-package_python2-pip-bootstrap() {
- depends=('python2')
- install=install2.sh
-
- mkdir -p "${pkgdir}/usr/bin"
- cp "${srcdir}/get-pip.py" "${pkgdir}/usr/bin/get-pip2.py"
-}
diff --git a/build-support/python-bootstrap/PKGBUILD b/build-support/python-bootstrap/PKGBUILD
deleted file mode 100644
index 2e42c71c..00000000
--- a/build-support/python-bootstrap/PKGBUILD
+++ /dev/null
@@ -1,45 +0,0 @@
-# Maintainer: Angel Velasquez <angvp@archlinux.org>
-# Maintainer: Felix Yan <felixonmars@archlinux.org>
-# Contributor: Eli Schwartz <eschwartz@archlinux.org>
-
-pkgname=python-bootstrap
-pkgver=3.11
-pkgrel=1
-pkgdesc="Python Bootstrap"
-arch=('any')
-license=('PSF')
-url="https://gitlab.archlinux.org/archlinux/python-bootstrap"
-depends=('python')
-makedepends=('git')
-provides=('python-build' 'python-flit' 'python-flit-core' 'python-installer''python-setuptools' 'python-wheel' 'python-tomli')
-source=("git+https://gitlab.archlinux.org/archlinux/python-bootstrap/#branch=$pkgver")
-sha512sums=('SKIP')
-
-export SETUPTOOLS_INSTALL_WINDOWS_SPECIFIC_FILES=0
-
-prepare() {
- cd "${srcdir}/${pkgname}"
- git submodule init; git submodule update
-}
-
-build() {
- cd "${srcdir}/${pkgname}"
- python -m bootstrap.build
-}
-
-wheels=(
- build-0.9.0-py3-none-any.whl
- flit_core-3.7.1-py3-none-any.whl
- installer-0.5.1-py3-none-any.whl
- pep517-0.13.0-py3-none-any.whl
- setuptools-58.3.0.post20230511-py3-none-any.whl
- tomli-2.0.1-py3-none-any.whl
- wheel-0.37.0-py2.py3-none-any.whl
-)
-
-package() {
- cd "${srcdir}/${pkgname}"
- for wheel in "${wheels[@]}"; do
- python -m bootstrap.install --destdir="$pkgdir" "dist/$wheel"
- done
-}
diff --git a/build-support/python-pip-bootstrap/PKGBUILD b/build-support/python-pip-bootstrap/PKGBUILD
new file mode 100644
index 00000000..4afb97a8
--- /dev/null
+++ b/build-support/python-pip-bootstrap/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Andreas Baumann <mail@andreasbaumann.cc>
+
+pkgname=('python-pip-bootstrap')
+pkgver=0.0.1
+pkgrel=2
+pkgdesc="bootstap pip and setuptools for bootstrapping python"
+arch=(i486 'i686' 'pentium4' 'x86_64' 'armv6h' 'armv7h')
+url="https://bootstrap.pypa.io/"
+source=("https://bootstrap.pypa.io/get-pip.py")
+sha512sums=('ba6c35de136e769bc67cbd41417c62ed2d7eebf893473ae3a98c50fd130b53fc02d7d9de266323197e30a4895c826c301a205595e129fb9e90d294d8f0e53afd')
+
+package_python-pip-bootstrap() {
+ depends=('python')
+ install=install.sh
+
+ mkdir -p "${pkgdir}/usr/bin"
+ cp "${srcdir}/get-pip.py" "${pkgdir}/usr/bin/."
+}
diff --git a/build-support/disabled/python-pip-bootstrap/install.sh b/build-support/python-pip-bootstrap/install.sh
index e81432e6..e81432e6 100644
--- a/build-support/disabled/python-pip-bootstrap/install.sh
+++ b/build-support/python-pip-bootstrap/install.sh
diff --git a/build-support/disabled/python-pip-bootstrap/install2.sh b/build-support/python-pip-bootstrap/install2.sh
index b6aa16fa..b6aa16fa 100644
--- a/build-support/disabled/python-pip-bootstrap/install2.sh
+++ b/build-support/python-pip-bootstrap/install2.sh