Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-09-28 17:15:02 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-09-28 17:15:02 +0200
commit06d0c1a6655160d7755bd71f3699388f951a83d5 (patch)
tree8e348bc794b541bff5a636882addbe95421a67aa
parentd9a1f22dbd055ff756fa324440994db58e4a9788 (diff)
community/clementine: using a differenc rc2
-rw-r--r--community/clementine/PKGBUILD67
-rw-r--r--community/clementine/clementine-1.4.0rc1-qpainterpath-missing-include.patch33
2 files changed, 16 insertions, 84 deletions
diff --git a/community/clementine/PKGBUILD b/community/clementine/PKGBUILD
index 49e4da25..0fb1fc6d 100644
--- a/community/clementine/PKGBUILD
+++ b/community/clementine/PKGBUILD
@@ -1,60 +1,25 @@
-# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
-# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
-# Contributor: BlackEagle <ike.devolder@gmail.com>
-# Contributor: Dany Martineau <dany.luc.martineau@gmail.com>
+# broken Github downloads (again)
+source=("https://github.com/clementine-player/Clementine/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('2395efdef013aa65ec8b8521d549bf76dbde4f933867be3953f31553101ead63')
-pkgname=clementine
-pkgver=1.4.0rc1
-pkgrel=3
-pkgdesc='A modern music player and library organizer'
-url=https://www.clementine-player.org/
-license=(GPL)
-arch=(x86_64 i486 i686 pentium4)
-depends=(chromaprint gst-plugins-base-libs libcdio libgpod liblastfm-qt5 libmtp libmygpo-qt5
- taglib protobuf qt5-x11extras projectm alsa-lib libpulse crypto++ hicolor-icon-theme)
-makedepends=(boost cmake qt5-tools sparsehash)
-optdepends=(
- 'gst-plugins-base: "Base" plugin libraries'
- 'gst-plugins-good: "Good" plugin libraries'
- 'gst-plugins-bad: "Bad" plugin libraries'
- 'gst-plugins-ugly: "Ugly" plugin libraries'
- 'gst-libav: Libav plugin'
- 'gvfs: Various devices support'
-)
-source=("https://github.com/clementine-player/Clementine/releases/download/${pkgver//+/-}/$pkgname-${pkgver//+/-}.tar.xz")
-sha256sums=('96ba2f5f3ece47b2c1065e980dcc37ada93ea42cf37b794ee804514ce4a65459')
-
-prepare() {
- sed -e 's|CRYPTOPP cryptopp|CRYPTOPP libcryptopp|' -i $pkgname-${pkgver//+/-}/CMakeLists.txt # Fix crypto++ detection
-}
-
-build() {
- cmake -B build -S $pkgname-${pkgver//+/-} \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DUSE_SYSTEM_PROJECTM=ON \
- -DUSE_SYSTEM_TAGLIB=ON
- cmake --build build
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --install build
-}
-
-# disable -Werror
+# of course the first level directory is different
+eval "$(
+ declare -f prepare | \
+ sed '
+ s|$pkgname-${pkgver//+/-}|Clementine-${pkgver}|g
+ '
+)"
eval "$(
declare -f build | \
sed '
- s|cmake -B build |cmake -B build -DBUILD_WERROR=OFF |
+ s|$pkgname-${pkgver//+/-}|Clementine-${pkgver}|g
'
)"
-# RC1 misses includes to QPainterPath
-source+=('clementine-1.4.0rc1-qpainterpath-missing-include.patch')
-sha256sums+=('64d538336a4f017abf1c6efa0973fc95eb1ac44aaf510b7c1e8a041113e1cdfd')
+# disable -Werror
eval "$(
- declare -f prepare \
- | sed '
- $ i cd $pkgname-$pkgver
- $ i patch -Np1 -i "$srcdir"/clementine-1.4.0rc1-qpainterpath-missing-include.patch
- '
+ declare -f build | \
+ sed '
+ s|cmake -B build |cmake -B build -DBUILD_WERROR=OFF |
+ '
)"
diff --git a/community/clementine/clementine-1.4.0rc1-qpainterpath-missing-include.patch b/community/clementine/clementine-1.4.0rc1-qpainterpath-missing-include.patch
deleted file mode 100644
index 49654005..00000000
--- a/community/clementine/clementine-1.4.0rc1-qpainterpath-missing-include.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -rauN clementine-1.4.0rc1/src/widgets/freespacebar.cpp clementine-1.4.0rc1-qpainterpath-missing-include-patch/src/widgets/freespacebar.cpp
---- clementine-1.4.0rc1/src/widgets/freespacebar.cpp 2020-01-02 22:53:03.000000000 +0100
-+++ clementine-1.4.0rc1-qpainterpath-missing-include-patch/src/widgets/freespacebar.cpp 2022-09-25 10:08:57.635983555 +0200
-@@ -20,6 +20,7 @@
-
- #include <QLinearGradient>
- #include <QPainter>
-+#include <QPainterPath>
-
- const int FreeSpaceBar::kBarHeight = 20;
- const int FreeSpaceBar::kBarBorderRadius = 8;
-diff -rauN clementine-1.4.0rc1/src/widgets/osdpretty.cpp clementine-1.4.0rc1-qpainterpath-missing-include-patch/src/widgets/osdpretty.cpp
---- clementine-1.4.0rc1/src/widgets/osdpretty.cpp 2020-01-02 22:53:03.000000000 +0100
-+++ clementine-1.4.0rc1-qpainterpath-missing-include-patch/src/widgets/osdpretty.cpp 2022-09-25 10:09:23.468658878 +0200
-@@ -26,6 +26,7 @@
- #include <QLayout>
- #include <QMouseEvent>
- #include <QPainter>
-+#include <QPainterPath>
- #include <QSettings>
- #include <QTimer>
- #include <QTimeLine>
-diff -rauN clementine-1.4.0rc1/src/widgets/sliderwidget.cpp clementine-1.4.0rc1-qpainterpath-missing-include-patch/src/widgets/sliderwidget.cpp
---- clementine-1.4.0rc1/src/widgets/sliderwidget.cpp 2020-01-02 22:53:03.000000000 +0100
-+++ clementine-1.4.0rc1-qpainterpath-missing-include-patch/src/widgets/sliderwidget.cpp 2022-09-25 10:09:36.561658722 +0200
-@@ -24,6 +24,7 @@
- #include <QBrush>
- #include <QImage>
- #include <QPainter>
-+#include <QPainterPath>
- #include <QSize>
- #include <QTimer>
- #include <QStyle>