Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/community/clementine/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/clementine/PKGBUILD')
-rw-r--r--community/clementine/PKGBUILD67
1 files changed, 16 insertions, 51 deletions
diff --git a/community/clementine/PKGBUILD b/community/clementine/PKGBUILD
index 49e4da25..0fb1fc6d 100644
--- a/community/clementine/PKGBUILD
+++ b/community/clementine/PKGBUILD
@@ -1,60 +1,25 @@
-# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
-# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
-# Contributor: BlackEagle <ike.devolder@gmail.com>
-# Contributor: Dany Martineau <dany.luc.martineau@gmail.com>
+# broken Github downloads (again)
+source=("https://github.com/clementine-player/Clementine/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('2395efdef013aa65ec8b8521d549bf76dbde4f933867be3953f31553101ead63')
-pkgname=clementine
-pkgver=1.4.0rc1
-pkgrel=3
-pkgdesc='A modern music player and library organizer'
-url=https://www.clementine-player.org/
-license=(GPL)
-arch=(x86_64 i486 i686 pentium4)
-depends=(chromaprint gst-plugins-base-libs libcdio libgpod liblastfm-qt5 libmtp libmygpo-qt5
- taglib protobuf qt5-x11extras projectm alsa-lib libpulse crypto++ hicolor-icon-theme)
-makedepends=(boost cmake qt5-tools sparsehash)
-optdepends=(
- 'gst-plugins-base: "Base" plugin libraries'
- 'gst-plugins-good: "Good" plugin libraries'
- 'gst-plugins-bad: "Bad" plugin libraries'
- 'gst-plugins-ugly: "Ugly" plugin libraries'
- 'gst-libav: Libav plugin'
- 'gvfs: Various devices support'
-)
-source=("https://github.com/clementine-player/Clementine/releases/download/${pkgver//+/-}/$pkgname-${pkgver//+/-}.tar.xz")
-sha256sums=('96ba2f5f3ece47b2c1065e980dcc37ada93ea42cf37b794ee804514ce4a65459')
-
-prepare() {
- sed -e 's|CRYPTOPP cryptopp|CRYPTOPP libcryptopp|' -i $pkgname-${pkgver//+/-}/CMakeLists.txt # Fix crypto++ detection
-}
-
-build() {
- cmake -B build -S $pkgname-${pkgver//+/-} \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DUSE_SYSTEM_PROJECTM=ON \
- -DUSE_SYSTEM_TAGLIB=ON
- cmake --build build
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --install build
-}
-
-# disable -Werror
+# of course the first level directory is different
+eval "$(
+ declare -f prepare | \
+ sed '
+ s|$pkgname-${pkgver//+/-}|Clementine-${pkgver}|g
+ '
+)"
eval "$(
declare -f build | \
sed '
- s|cmake -B build |cmake -B build -DBUILD_WERROR=OFF |
+ s|$pkgname-${pkgver//+/-}|Clementine-${pkgver}|g
'
)"
-# RC1 misses includes to QPainterPath
-source+=('clementine-1.4.0rc1-qpainterpath-missing-include.patch')
-sha256sums+=('64d538336a4f017abf1c6efa0973fc95eb1ac44aaf510b7c1e8a041113e1cdfd')
+# disable -Werror
eval "$(
- declare -f prepare \
- | sed '
- $ i cd $pkgname-$pkgver
- $ i patch -Np1 -i "$srcdir"/clementine-1.4.0rc1-qpainterpath-missing-include.patch
- '
+ declare -f build | \
+ sed '
+ s|cmake -B build |cmake -B build -DBUILD_WERROR=OFF |
+ '
)"