Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/rebuildpkgs.in
diff options
context:
space:
mode:
authorLevente Polyak <anthraxx@archlinux.org>2022-05-18 02:31:26 +0200
committerLevente Polyak <anthraxx@archlinux.org>2022-06-22 01:05:02 +0200
commitd94badcd0be4f1f0bdc85a9e17f622373fcc42b2 (patch)
tree09755c43df16dd47d8f99c15213c49315219cb71 /rebuildpkgs.in
parente1a51770b26f3b36f24dc5668253eda23a8c8bcf (diff)
make: split out source files into src folder
Diffstat (limited to 'rebuildpkgs.in')
-rw-r--r--rebuildpkgs.in111
1 files changed, 0 insertions, 111 deletions
diff --git a/rebuildpkgs.in b/rebuildpkgs.in
deleted file mode 100644
index 164bf08..0000000
--- a/rebuildpkgs.in
+++ /dev/null
@@ -1,111 +0,0 @@
-#!/bin/bash
-#
-# SPDX-License-Identifier: GPL-3.0-or-later
-#
-# This script rebuilds a list of packages in order
-# and reports anything that fails
-#
-# Due to sudo usage, it is recommended to allow makechrootpkg
-# to be run with NOPASSWD in your sudoers file
-#
-# FIXME
-# Currently uses $(pwd)/rebuilds as the directory for rebuilding...
-# TODO make this work for community too
-
-m4_include(lib/common.sh)
-
-if (( $# < 1 )); then
- printf 'Usage: %s <chrootdir> <packages to rebuild>\n' "$(basename "${BASH_SOURCE[0]}")"
- printf ' example: %s ~/chroot readline bash foo bar baz\n' "$(basename "${BASH_SOURCE[0]}")"
- exit 1
-fi
-
-# Source makepkg.conf; fail if it is not found
-if [[ -r '/etc/makepkg.conf' ]]; then
- # shellcheck source=config/makepkg/x86_64.conf
- source '/etc/makepkg.conf'
-else
- die '/etc/makepkg.conf not found!'
-fi
-
-# Source user-specific makepkg.conf overrides
-if [[ -r "${XDG_CONFIG_HOME:-$HOME/.config}/pacman/makepkg.conf" ]]; then
- # shellcheck source=/dev/null
- source "${XDG_CONFIG_HOME:-$HOME/.config}/pacman/makepkg.conf"
-elif [[ -r "$HOME/.makepkg.conf" ]]; then
- # shellcheck source=/dev/null
- source "$HOME/.makepkg.conf"
-fi
-
-bump_pkgrel() {
- # Get the current pkgrel from SVN and update the working copy with it
- # This prevents us from incrementing out of control :)
- pbuild='.svn/text-base/PKGBUILD.svn-base'
- oldrel=$(grep 'pkgrel=' $pbuild | cut -d= -f2)
-
- #remove decimals
- rel=${oldrel%%.*}
-
- newrel=$((rel + 1))
-
- sed -i "s/pkgrel=$oldrel/pkgrel=$newrel/" PKGBUILD
-}
-
-pkg_from_pkgbuild() {
- # we want the sourcing to be done in a subshell so we don't pollute our current namespace
- export CARCH PKGEXT
- # shellcheck source=PKGBUILD.proto
- (source PKGBUILD; echo "$pkgname-$pkgver-$pkgrel-$CARCH$PKGEXT")
-}
-
-chrootdir="$1"; shift
-pkgs=("$@")
-
-SVNPATH='svn+ssh://repos.archlinux.org/srv/repos/svn-packages/svn'
-
-msg "Work will be done in %s" "$(pwd)/rebuilds"
-
-REBUILD_ROOT="$(pwd)/rebuilds"
-mkdir -p "$REBUILD_ROOT"
-cd "$REBUILD_ROOT"
-
-/usr/bin/svn co -N $SVNPATH
-
-FAILED=""
-for pkg in "${pkgs[@]}"; do
- cd "$REBUILD_ROOT/svn-packages"
-
- msg2 "Building '%s'" "$pkg"
- /usr/bin/svn update "$pkg"
- if [[ ! -d "$pkg/trunk" ]]; then
- FAILED="$FAILED $pkg"
- warning "%s does not exist in SVN" "$pkg"
- continue
- fi
- cd "$pkg/trunk/"
-
- bump_pkgrel
-
- if ! sudo makechrootpkg -u -d -r "$chrootdir" -- --noconfirm; then
- FAILED="$FAILED $pkg"
- error "%s Failed!" "$pkg"
- else
- pkgfile=$(pkg_from_pkgbuild)
- if [[ -e $pkgfile ]]; then
- msg2 "%s Complete" "$pkg"
- else
- FAILED="$FAILED $pkg"
- error "%s Failed, no package built!" "$pkg"
- fi
- fi
-done
-
-cd "$REBUILD_ROOT"
-if [[ -n $FAILED ]]; then
- msg 'Packages failed:'
- for pkg in $FAILED; do
- msg2 "%s" "$pkg"
- done
-fi
-
-msg 'SVN pkgbumps in svn-packages/ - commit when ready'