Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 579ff2ed..f76a647b 100644
--- a/meson.build
+++ b/meson.build
@@ -146,7 +146,9 @@ foreach sym : [
'tcflush',
]
have = cc.has_function(sym, args : '-D_GNU_SOURCE')
- conf.set10('HAVE_' + sym.to_upper(), have)
+ if have
+ conf.set10('HAVE_' + sym.to_upper(), have)
+ endif
endforeach
foreach member : [