Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2021-01-05 00:48:11 +0000
committerAllan McRae <allan@archlinux.org>2021-01-09 00:14:33 +1000
commitd53ba019f5dfee00fd66491c1fa1ac8978fd628d (patch)
tree906b465457239aa32040322d1771c12573f8106d /meson.build
parent793e2097a6f46bbc5048c540e32a4caf92a6836a (diff)
meson: pacman-conf add missing libcommon link
Currently, we are erroneously exporting all the symbols via the libalpm.so. As such, the libcommon dependency is resolved. The libalpm.so exports are about to be resolved shortly, yet that exposed that pacman-conf is missing a link against libcommon. Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com> Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 2002dc78..71a3b54e 100644
--- a/meson.build
+++ b/meson.build
@@ -347,7 +347,7 @@ executable(
'pacman-conf',
pacman_conf_sources,
include_directories : includes,
- link_with : [libalpm],
+ link_with : [libalpm, libcommon],
dependencies : [libarchive],
install : true,
)