Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan McGee <dan@archlinux.org>2012-04-29 20:27:32 -0500
committerDan McGee <dan@archlinux.org>2012-04-29 20:27:32 -0500
commit8c7202ca19361c35357140b0e3083cfa5bc12d21 (patch)
tree26111b943283582e4d4962138aa6e0fb1c70b5b9 /configure.ac
parent9dd42dc0daab510a4e68118d89b5543936d2074f (diff)
parent82b7122542e16354b560bae9c7f6f3608873a8e1 (diff)
Merge remote-tracking branch 'dave/buildsys'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 18 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d488bfaf..15e93e71 100644
--- a/configure.ac
+++ b/configure.ac
@@ -148,7 +148,23 @@ AC_PROG_AWK
AC_PROG_CC_C99
AC_PROG_INSTALL
AC_CHECK_PROGS([PYTHON], [python2.7 python2.6 python2.5 python2 python], [false])
-AC_PATH_PROGS([BASH_SHELL], [bash bash4 bash3], [false])
+AC_PATH_PROGS([BASH_SHELL], [bash bash4], [false])
+
+AS_IF([test "x$BASH_SHELL" = "xfalse"],
+ AC_MSG_WARN([*** bash >= 4.1.0 is required for pacman scripts]),
+ [bash_version_major=`$BASH_SHELL -c 'echo "${BASH_VERSINFO[[0]]}"'`
+ bash_version_minor=`$BASH_SHELL -c 'echo "${BASH_VERSINFO[[1]]}"'`
+ ok=yes
+ if test "$bash_version_major" -lt 4; then
+ ok=no
+ fi
+ if test "$bash_version_major" -eq 4 && test "$bash_version_minor" -lt 1; then
+ ok=no
+ fi
+ if test "$ok" = "no"; then
+ AC_MSG_ERROR([*** bash >= 4.1.0 is required for pacman scripts])
+ fi
+ unset bash_version_major bash_version_minor ok])
# find installed gettext
AM_GNU_GETTEXT([external], [need-ngettext])
@@ -433,6 +449,7 @@ AC_DEFINE_UNQUOTED([SCRIPTLET_SHELL], "$SCRIPTLET_SHELL", [The full path of the
AC_CONFIG_FILES([
lib/libalpm/Makefile
lib/libalpm/po/Makefile.in
+lib/libalpm/libalpm.pc
src/pacman/Makefile
src/pacman/po/Makefile.in
src/util/Makefile