Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAllan McRae <allan@archlinux.org>2019-11-05 15:25:52 +1000
committerAllan McRae <allan@archlinux.org>2019-11-05 15:25:52 +1000
commit27955a0fee16f817b5569e0bc29bc1498a87ea68 (patch)
tree842859c2d69f8414cd86c519d895d85c21ae5e7c /Makefile.am
parent1bfae7d14a7bdad777e82912c5c6883deb11aee5 (diff)
Move update-copyright into build-aux
This is a useful function to update all our copyright years. Move it into build-aux so that it is not lost in the switch to meson. Signed-off-by: Allan McRae <allan@archlinux.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 1 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index c661f447..851bf472 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -77,9 +77,4 @@ update-po:
$(MAKE) -C scripts/po update-po
$(MAKE) -C src/pacman/po update-po
-update-copyright:
- for file in $(shell sh -c 'git grep -l "Copyright .* Pacman Development" | grep -v "\.po"'); do \
- sed -i -e "/Copyright (/s/-$(OLD)/-$(NEW)/" -e "/Copyright (/s/ $(OLD)/ $(OLD)-$(NEW)/" "$$file"; \
- done
-
-.PHONY: update-po update-copyright
+.PHONY: update-po