Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/tinyemu/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/tinyemu/PKGBUILD')
-rw-r--r--extra/tinyemu/PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/extra/tinyemu/PKGBUILD b/extra/tinyemu/PKGBUILD
new file mode 100644
index 00000000..b7af84e1
--- /dev/null
+++ b/extra/tinyemu/PKGBUILD
@@ -0,0 +1,11 @@
+# disable 128 bit RISCV on 32-bit targets, not supported
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i sed -i s/^CONFIG_INT128=.*/#CONFIG_INT128=n/ "$m"
+ '
+)"
+