Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/samba/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/samba/PKGBUILD')
-rw-r--r--extra/samba/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/extra/samba/PKGBUILD b/extra/samba/PKGBUILD
new file mode 100644
index 00000000..131948ae
--- /dev/null
+++ b/extra/samba/PKGBUILD
@@ -0,0 +1,26 @@
+# disable CEPH support
+makedepends=(${makedepends[@]//ceph-libs/})
+
+eval "$(
+ declare -f package_samba | \
+ sed '
+ /depends/ a \
+ depends=(${depends[@]//ceph-libs/})
+ '
+)"
+
+eval "$(
+ declare -f build | \
+ sed '
+ s|./configure|./configure --disable-cephfs|
+ '
+)"
+
+if test "$CARCH" == "i486"; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s|./configure|LDFLAGS=-latomic ./configure|
+ '
+ )"
+fi