Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/rust
diff options
context:
space:
mode:
Diffstat (limited to 'extra/rust')
-rw-r--r--extra/rust/PKGBUILD10
-rw-r--r--extra/rust/config.toml.patch26
2 files changed, 15 insertions, 21 deletions
diff --git a/extra/rust/PKGBUILD b/extra/rust/PKGBUILD
index 14ddf770..7066b7eb 100644
--- a/extra/rust/PKGBUILD
+++ b/extra/rust/PKGBUILD
@@ -6,12 +6,12 @@
# see https://github.com/rust-lang/rust/issues/60294
source+=(config.toml.patch)
-b2sums+=('916e62176ff8f943428532c28ec31632c153db5a9e906ae7a45df88cac72d437d23a56eb05e915ea2b2f524ac96d0b9ff8c106ed82572f7ed3324ded3fcf5a74')
+b2sums+=('b438042bad72f2952b135a46ca7353b0f333f58b7e5658e0f08fed75eba5095407aca479cbd6911fbaf2aa26482dce047293cf7114ace537b15acc8f10223551')
eval "$(
declare -f prepare | \
sed '
- $ i patch -p1 -i "$srcdir/config.toml.patch"
+ $ i patch -p0 -i "$srcdir/config.toml.patch"
'
)"
@@ -68,6 +68,7 @@ pkgname=(
)
)
makedepends=(${makedepends[@]//lib32-gcc-libs/})
+makedepends=(${makedepends[@]//lib32-glibc/})
# Enable on demand, if your previous rust is broken use previous version
# from build-support (this is preferable to using rust-bin below, but
@@ -77,8 +78,9 @@ makedepends=(${makedepends[@]//lib32-gcc-libs/})
# Enable on demand, if your previous rust is broken use previous version
# from build-support
-makedepends=(${makedepends[@]//rust/})
-makedepends+=('rust176-bin')
+#makedepends=(${makedepends[@]//rust/})
+#makedepends+=('rust176-bin')
# Do not run out of memory linking LLVM
options+=(!debug)
+
diff --git a/extra/rust/config.toml.patch b/extra/rust/config.toml.patch
index 20b8e24b..c002cff6 100644
--- a/extra/rust/config.toml.patch
+++ b/extra/rust/config.toml.patch
@@ -1,11 +1,6 @@
---- a/config.toml 2024-03-12 15:14:24.314876558 +0000
-+++ b/config.toml 2024-03-20 14:09:23.793371221 +0000
-@@ -3,14 +3,15 @@
-
- [llvm]
- link-shared = true
-+link-jobs = 1
-+use-linker = "bfd"
+--- config.toml.orig 2024-05-06 00:02:38.463811257 +0000
++++ config.toml 2024-05-06 00:57:21.364799544 +0000
+@@ -6,9 +6,8 @@
[build]
target = [
@@ -14,21 +9,18 @@
- "x86_64-unknown-linux-musl",
+ "i686-unknown-linux-musl",
"wasm32-unknown-unknown",
-- "wasm32-wasi",
-+ "wasm32-wasi"
+ "wasm32-wasi",
]
- cargo = "/usr/bin/cargo"
- rustc = "/usr/bin/rustc"
-@@ -37,7 +38,7 @@
- prefix = "/usr"
-
+@@ -39,7 +38,7 @@
[rust]
+ codegen-units-std = 1
+ debuginfo-level = 1
-debuginfo-level-std = 2
-+debuginfo-level-std = 0
++debuginfo-level-std = 1
channel = "stable"
description = "Arch Linux :-"
rpath = false
-@@ -74,7 +75,7 @@
+@@ -65,7 +64,7 @@
ar = "/usr/bin/gcc-ar"
ranlib = "/usr/bin/gcc-ranlib"