Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/ruby/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/ruby/PKGBUILD')
-rw-r--r--extra/ruby/PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/extra/ruby/PKGBUILD b/extra/ruby/PKGBUILD
index 2ee10842..b03abc17 100644
--- a/extra/ruby/PKGBUILD
+++ b/extra/ruby/PKGBUILD
@@ -1,3 +1,6 @@
+# Hack
+eval "$(declare -f build | sed 's@./configure@./configure --with-search-path=/usr/lib/ruby/${pkgver:0:3}.0/x86-linux@')"
+
# patch architecture in helper shared libs
if [ "${CARCH}" = "pentium4" -o "${CARCH}" = "i686" ]; then
eval "$(