Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/ruby/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/ruby/PKGBUILD')
-rw-r--r--extra/ruby/PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/extra/ruby/PKGBUILD b/extra/ruby/PKGBUILD
new file mode 100644
index 00000000..b03abc17
--- /dev/null
+++ b/extra/ruby/PKGBUILD
@@ -0,0 +1,20 @@
+# Hack
+eval "$(declare -f build | sed 's@./configure@./configure --with-search-path=/usr/lib/ruby/${pkgver:0:3}.0/x86-linux@')"
+
+# patch architecture in helper shared libs
+if [ "${CARCH}" = "pentium4" -o "${CARCH}" = "i686" ]; then
+ eval "$(
+ declare -f package_ruby | \
+ sed '
+ s|x86_64-linux|i686-linux|g
+ '
+ )"
+fi
+if [ "${CARCH}" = "i486" ]; then
+ eval "$(
+ declare -f package_ruby | \
+ sed '
+ s|x86_64-linux|i486-linux|g
+ '
+ )"
+fi