Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/quazip/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/quazip/PKGBUILD')
-rw-r--r--extra/quazip/PKGBUILD14
1 files changed, 14 insertions, 0 deletions
diff --git a/extra/quazip/PKGBUILD b/extra/quazip/PKGBUILD
new file mode 100644
index 00000000..a3ff50a4
--- /dev/null
+++ b/extra/quazip/PKGBUILD
@@ -0,0 +1,14 @@
+# build with non-probing CMakeLists.txt the qt5 version, assuming both
+# qt6 and qt5 artifacts are installed which make the automatic guesser
+# recognize the major version of Qt
+# (see also upstream FS#76054)
+source+=('CMakeLists-Qt5.txt')
+sha256sums+=('44378ad0642f14173b4d3b2f98332546d88ffe045db465c415d9c37708fdb1ea')
+eval "$(
+ declare -f build | \
+ sed '
+ /cmake -B build5/ i cp $pkgbase-$pkgver/CMakeLists.txt CMakeLists.bak \
+ cp CMakeLists-Qt5.txt $pkgbase-$pkgver/CMakeLists.txt
+ /cmake -B build6/ i cp CMakeLists.bak $pkgbase-$pkgver/CMakeLists.txt
+ '
+)"