Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/qt6-base
diff options
context:
space:
mode:
Diffstat (limited to 'extra/qt6-base')
-rw-r--r--extra/qt6-base/PKGBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/extra/qt6-base/PKGBUILD b/extra/qt6-base/PKGBUILD
index 5ce557f9..131ce0c0 100644
--- a/extra/qt6-base/PKGBUILD
+++ b/extra/qt6-base/PKGBUILD
@@ -9,3 +9,11 @@ if [ "$CARCH" = 'i486' ]; then
'
)"
fi
+
+# Fix SSE2 issues on i486/i686
+if [ "$CARCH" = 'i486' -o "$CARCH" = 'i686' ]; then
+ eval "$(
+ declare -f prepare | \
+ sed '$ d' | sed '$ a sed -i s/defined\\(__FLT16_MAX__\\)/0/ src/corelib/global/qtypes.h; }'
+ )"
+fi