Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/qt6-base
diff options
context:
space:
mode:
authorTasos Sahanidis <tasos@tasossah.com>2024-07-10 06:34:50 +0300
committerTasos Sahanidis <tasos@tasossah.com>2024-07-10 06:34:50 +0300
commit2861645cace459bc87130be331fde4100f15def3 (patch)
treeedfe9f0e05f43b702e842f5a847cc452a857a7d2 /extra/qt6-base
parent0d670695ae078c1c8e8d8aca660d8555fa60d3a3 (diff)
extra/qt6-base: Fix non SSE2 builds
Diffstat (limited to 'extra/qt6-base')
-rw-r--r--extra/qt6-base/PKGBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/extra/qt6-base/PKGBUILD b/extra/qt6-base/PKGBUILD
index 5ce557f9..131ce0c0 100644
--- a/extra/qt6-base/PKGBUILD
+++ b/extra/qt6-base/PKGBUILD
@@ -9,3 +9,11 @@ if [ "$CARCH" = 'i486' ]; then
'
)"
fi
+
+# Fix SSE2 issues on i486/i686
+if [ "$CARCH" = 'i486' -o "$CARCH" = 'i686' ]; then
+ eval "$(
+ declare -f prepare | \
+ sed '$ d' | sed '$ a sed -i s/defined\\(__FLT16_MAX__\\)/0/ src/corelib/global/qtypes.h; }'
+ )"
+fi