Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/qt5-webengine
diff options
context:
space:
mode:
Diffstat (limited to 'extra/qt5-webengine')
-rw-r--r--extra/qt5-webengine/PKGBUILD15
-rw-r--r--extra/qt5-webengine/qtwebengine-everywhere-src-5.15.0-gcc10-patches.patch10
-rw-r--r--extra/qt5-webengine/qtwebengine-everywhere-src-5.15.2-glibc-2.33.patch81
3 files changed, 88 insertions, 18 deletions
diff --git a/extra/qt5-webengine/PKGBUILD b/extra/qt5-webengine/PKGBUILD
index 7af5e50c..a3e2bbd3 100644
--- a/extra/qt5-webengine/PKGBUILD
+++ b/extra/qt5-webengine/PKGBUILD
@@ -23,17 +23,16 @@ eval "$(
'
)"
-# redone patch, see also https://bugs.gentoo.org/721876
-# most is now fixed upstream in 5.15.0, patch for
-# src/3rdparty/chromium/third_party/webrtc/modules/video_coding/decoding_state.h
-# might be superfluous, but testing takes too much time, so keeping it for now.
-# (IMHO it would include cstdint just by accident, the header file need uintxx_t)
-source+=('qtwebengine-everywhere-src-5.15.0-gcc10-patches.patch')
-sha256sums+=('b41d4eca4c75c6d8115444ac4b10b8aa0f742d3ce64077d77eb4fb2079d0a42c')
+# glibc 2.33, some more tim64-affected functions for seccomp (futex_time64,
+# pselect6_time64), also added missing network functions for __i386__ and missing statx
+# (see also FS32#162)
+source+=('qtwebengine-everywhere-src-5.15.2-glibc-2.33.patch')
+sha256sums+=('4e0ea86259df3274ff917c16b1651fc5eb56521829b0eb77302c0e25b44e95b8')
eval "$(
declare -f prepare | \
sed '
- $ i cd "$srcdir/${_pkgfqn}"; patch -Np1 -i "${srcdir}"/qtwebengine-everywhere-src-5.15.0-gcc10-patches.patch
+ /patch.*qtwebengine-everywhere-src-5.15.0-sandbox-Aw-snap-for-syscalls-403-and-407/ a \
+ patch -Np1 -i "${srcdir}"/qtwebengine-everywhere-src-5.15.2-glibc-2.33.patch
'
)"
diff --git a/extra/qt5-webengine/qtwebengine-everywhere-src-5.15.0-gcc10-patches.patch b/extra/qt5-webengine/qtwebengine-everywhere-src-5.15.0-gcc10-patches.patch
deleted file mode 100644
index 2db3d074..00000000
--- a/extra/qt5-webengine/qtwebengine-everywhere-src-5.15.0-gcc10-patches.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- qtwebengine-everywhere-src-5.15.0/src/3rdparty/chromium/third_party/webrtc/modules/video_coding/decoding_state.h 2020-05-06 16:21:29.000000000 +0200
-+++ qtwebengine-everywhere-src-5.15.0-gcc10-patches-patch/src/3rdparty/chromium/third_party/webrtc/modules/video_coding/decoding_state.h 2020-06-04 12:07:20.407353742 +0200
-@@ -13,6 +13,7 @@
-
- #include <map>
- #include <set>
-+#include <cstdint>
- #include <vector>
-
- namespace webrtc {
diff --git a/extra/qt5-webengine/qtwebengine-everywhere-src-5.15.2-glibc-2.33.patch b/extra/qt5-webengine/qtwebengine-everywhere-src-5.15.2-glibc-2.33.patch
new file mode 100644
index 00000000..6617381e
--- /dev/null
+++ b/extra/qt5-webengine/qtwebengine-everywhere-src-5.15.2-glibc-2.33.patch
@@ -0,0 +1,81 @@
+diff -rauN qtwebengine-everywhere-src-5.15.2/src/3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/baseline_policy.cc qtwebengine-everywhere-src-5.15.2-glibc-2.33-patch/src/3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/baseline_policy.cc
+--- qtwebengine-everywhere-src-5.15.2/src/3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/baseline_policy.cc 2021-02-28 20:45:08.235833271 +0100
++++ qtwebengine-everywhere-src-5.15.2-glibc-2.33-patch/src/3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/baseline_policy.cc 2021-02-28 20:31:10.781033251 +0100
+@@ -189,7 +189,11 @@
+ }
+ #endif
+
+- if (sysno == __NR_futex)
++ if (sysno == __NR_futex
++#if defined(__NR_futex_time64)
++ || sysno == __NR_futex_time64
++#endif
++ )
+ return RestrictFutex();
+
+ if (sysno == __NR_set_robust_list)
+@@ -235,7 +239,7 @@
+ return RestrictPrctl();
+
+ #if defined(__x86_64__) || defined(__arm__) || defined(__mips__) || \
+- defined(__aarch64__)
++ defined(__aarch64__) || defined(__i386__)
+ if (sysno == __NR_socketpair) {
+ // Only allow AF_UNIX, PF_UNIX. Crash if anything else is seen.
+ static_assert(AF_UNIX == PF_UNIX,
+diff -rauN qtwebengine-everywhere-src-5.15.2/src/3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_sets.cc qtwebengine-everywhere-src-5.15.2-glibc-2.33-patch/src/3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_sets.cc
+--- qtwebengine-everywhere-src-5.15.2/src/3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_sets.cc 2021-02-28 20:45:08.269166536 +0100
++++ qtwebengine-everywhere-src-5.15.2-glibc-2.33-patch/src/3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/syscall_sets.cc 2021-02-28 20:31:19.874344479 +0100
+@@ -563,6 +563,9 @@
+ #endif
+ case __NR_ppoll:
+ case __NR_pselect6:
++#if defined(__i386__)
++ case __NR_pselect6_time64:
++#endif
+ case __NR_read:
+ case __NR_readv:
+ case __NR_pread64:
+@@ -571,7 +574,7 @@
+ case __NR_recv:
+ #endif
+ #if defined(__x86_64__) || defined(__arm__) || defined(__mips__) || \
+- defined(__aarch64__)
++ defined(__aarch64__) || defined(__i386__)
+ case __NR_recvfrom: // Could specify source.
+ case __NR_recvmsg: // Could specify source.
+ #endif
+@@ -586,7 +589,7 @@
+ case __NR_send:
+ #endif
+ #if defined(__x86_64__) || defined(__arm__) || defined(__mips__) || \
+- defined(__aarch64__)
++ defined(__aarch64__) || defined(__i386__)
+ case __NR_sendmsg: // Could specify destination.
+ case __NR_sendto: // Could specify destination.
+ #endif
+diff -rauN qtwebengine-everywhere-src-5.15.2/src/3rdparty/chromium/sandbox/linux/system_headers/x86_32_linux_syscalls.h qtwebengine-everywhere-src-5.15.2-glibc-2.33-patch/src/3rdparty/chromium/sandbox/linux/system_headers/x86_32_linux_syscalls.h
+--- qtwebengine-everywhere-src-5.15.2/src/3rdparty/chromium/sandbox/linux/system_headers/x86_32_linux_syscalls.h 2020-11-07 02:22:36.000000000 +0100
++++ qtwebengine-everywhere-src-5.15.2-glibc-2.33-patch/src/3rdparty/chromium/sandbox/linux/system_headers/x86_32_linux_syscalls.h 2021-02-28 20:31:15.447688573 +0100
+@@ -446,6 +446,10 @@
+ #define __NR_fstat 108
+ #endif
+
++#if !defined(__NR_statx)
++#define __NR_statx 383
++#endif
++
+ #if !defined(__NR_olduname)
+ #define __NR_olduname 109
+ #endif
+@@ -966,6 +970,10 @@
+ #define __NR_futex 240
+ #endif
+
++#if !defined(__NR_futex_time64)
++#define __NR_futex_time64 422
++#endif
++
+ #if !defined(__NR_sched_setaffinity)
+ #define __NR_sched_setaffinity 241
+ #endif