Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/qt5-webengine/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/qt5-webengine/PKGBUILD')
-rw-r--r--extra/qt5-webengine/PKGBUILD14
1 files changed, 14 insertions, 0 deletions
diff --git a/extra/qt5-webengine/PKGBUILD b/extra/qt5-webengine/PKGBUILD
index 3a6bd03e..9da2d7d4 100644
--- a/extra/qt5-webengine/PKGBUILD
+++ b/extra/qt5-webengine/PKGBUILD
@@ -50,3 +50,17 @@ eval "$(
$ i cd "$srcdir/${_pkgfqn}"; patch -Np1 -i "${srcdir}"/qtwebengine-everywhere-src-5.15.0-sandbox-Aw-snap-for-syscalls-403-and-407.patch
'
)"
+
+# glibc 2.33, some more tim64-affected functions for seccomp (futex_time64,
+# pselect6_time64), also added missing network functions for __i386__ and missing statx
+# (see also FS32#162)
+source+=('qtwebengine-everywhere-src-5.15.2-glibc-2.33.patch')
+sha256sums+=('6504c3a3ea58f9e870ba2108c9000f9ca7fb3dfb52213d79aa946c94f886b63a')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ /patch.*qtwebengine-everywhere-src-5.15.0-sandbox-Aw-snap-for-syscalls-403-and-407/ a \
+ patch -Np1 -i "${srcdir}"/qtwebengine-everywhere-src-5.15.2-glibc-2.33.patch
+ '
+)"