Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/qt5-base/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/qt5-base/PKGBUILD')
-rw-r--r--extra/qt5-base/PKGBUILD35
1 files changed, 31 insertions, 4 deletions
diff --git a/extra/qt5-base/PKGBUILD b/extra/qt5-base/PKGBUILD
index 8b08f917..7b301389 100644
--- a/extra/qt5-base/PKGBUILD
+++ b/extra/qt5-base/PKGBUILD
@@ -7,14 +7,41 @@ if [ "$CARCH" = 'i486' -o "$CARCH" = 'i686' ]; then
)"
fi
-makedepends=(${makedepends[@]/vulkan-headers/})
-makedepends_i686+=(vulkan-headers)
-makedepends_pentium4=("${makedepends_i686[@]}")
+# enable XCB explicitely for now on i486 (rather fail early than to
+# get weird startup messages of Qt5 applications hours later)
if [ "$CARCH" = 'i486' ]; then
eval "$(
declare -f build | \
sed '
- s@./configure@./configure -no-feature-vulkan@g
+ s/configure/configure -xcb /
+ '
+ )"
+fi
+
+# no LTO on i486
+if [ "$CARCH" = 'i486' ]; then
+ sed -i '
+ 1i options=(!lto)
+ ' PKGBUILD
+fi
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/-ltcg/-no-ltcg/
+ s/\(.*qmake *\)CONFIG+=fat-static-lto\(.*\)/\1 \2/
+ '
+ )"
+fi
+# -no-ltcg is partially ignored, patching it directly in the mkspecs
+source+=('qtbase-no-ltcg-broken.patch')
+sha256sums+=('024549dbb8cc76921c16070b4cf1253e88fd33f78d6756e2ee398c405b8d1979')
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f prepare | \
+ sed '
+ $ i \
+ patch -p1 < ../qtbase-no-ltcg-broken.patch
'
)"
fi