Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/qemu/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/qemu/PKGBUILD')
-rw-r--r--extra/qemu/PKGBUILD14
1 files changed, 13 insertions, 1 deletions
diff --git a/extra/qemu/PKGBUILD b/extra/qemu/PKGBUILD
index cedabcb1..fc07d90f 100644
--- a/extra/qemu/PKGBUILD
+++ b/extra/qemu/PKGBUILD
@@ -1,4 +1,4 @@
-# ceph doesn't run on 32-xit currently (see FS32#21)
+# ceph doesn't run on 32-bit currently (see FS32#21)
makedepends=(${makedepends[@]/ceph})
@@ -22,3 +22,15 @@ eval "$(
depends=(${depends[@]//edk2-armvirt/})
'
)"
+
+# qemu: /startdir/PKGBUILD: line 436: cd: /build/qemu/pkg/qemu-common/usr/share/man/man1: No such file or directory
+# We'll live with invalid symlinks for now
+eval "$(
+ declare -f package_qemu-common | \
+ sed 's@\(usr/share/man/man.*\);@\1 || true;@ ; s@\(.*usr/share/doc/qemu.*\);@\1 || true;@'
+)"
+
+eval "$(
+ declare -f package_qemu-docs | \
+ sed 's@\(mv -v $pkgname/*.*\);@\1 || true;@'
+)"