Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/python2/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/python2/PKGBUILD')
-rw-r--r--extra/python2/PKGBUILD34
1 files changed, 0 insertions, 34 deletions
diff --git a/extra/python2/PKGBUILD b/extra/python2/PKGBUILD
deleted file mode 100644
index 8a8c26ff..00000000
--- a/extra/python2/PKGBUILD
+++ /dev/null
@@ -1,34 +0,0 @@
-# on i686 some tests fail with segfault
-# test_replace_overflow (present in test_bytes, test_str, test_string,
-# test_unicode, test_userstring) segfault on i686
-# test_bigrepeat (present in test_tuple) segfault on i686
-
-# tests run with -j4 per default effectively killing build slaves,
-# forcing single threaded execution of tests
-
-eval "$(
- declare -f build | \
- sed '
- /export OPT=/ s/";$/ -fwrapv";/
- s/make/make EXTRATESTOPTS='"'"'-j 1'"'"' /
- '
- declare -f check | \
- sed '
- /xvfb-run/ s/-x test_idle/-x test_idle test_bytes test_str test_string test_unicode test_userstring test_tuple test_ssl test_httplib test_urllibnet/
- s/ -m test.regrtest/ -m test.regrtest -j1/
- '
-)"
-
-checkdepends=(${makedepends[@]//xorg-server-xvfb/})
-checkdepends_i686+=(xorg-server-xvfb)
-checkdepends_pentium4=("${checkdepends_i686[@]}")
-
-# skip xvfb stuff on i486
-if [ "$CARCH" = 'i486' ]; then
- eval "$(
- declare -f check | \
- sed '
- s/xvfb-run //
- '
- )"
-fi