Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/python-tqdm/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/python-tqdm/PKGBUILD')
-rw-r--r--extra/python-tqdm/PKGBUILD15
1 files changed, 15 insertions, 0 deletions
diff --git a/extra/python-tqdm/PKGBUILD b/extra/python-tqdm/PKGBUILD
new file mode 100644
index 00000000..d02a290a
--- /dev/null
+++ b/extra/python-tqdm/PKGBUILD
@@ -0,0 +1,15 @@
+# https://github.com/tqdm/tqdm/issues/538
+
+source+=('tqdm-4.22.0-sleep-test-workaround.patch')
+sha512sums+=('ac09e7578ad380f55f9371a067061bd1f23be6a799ec82c3abf2471d7d780bd435b423d0ab1f989cf7039b467d5adfa38e324cb887b0b27f52218fa3753956fa')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ /cp/ i pushd ${srcdir}/tqdm-$pkgver && patch -Np1 -i "${srcdir}"/tqdm-4.22.0-sleep-test-workaround.patch && popd
+ '
+)"
+
+# Check depends on python-keras which depends on tensorflow
+unset check
+unset checkdepends