Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/python-shapely/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/python-shapely/PKGBUILD')
-rw-r--r--extra/python-shapely/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/extra/python-shapely/PKGBUILD b/extra/python-shapely/PKGBUILD
new file mode 100644
index 00000000..14ce07a9
--- /dev/null
+++ b/extra/python-shapely/PKGBUILD
@@ -0,0 +1,23 @@
+# temporary fix for:
+# - https://github.com/Toblerity/Shapely/pull/762
+#
+# which caused:
+# - https://community.ultimaker.com/topic/29721-archlinux32-cura-341/?_fromLogin=1#replyForm
+#
+source+=(load_dll_c.patch)
+sha512sums+=('6dee4823b76d5057beaed09e9ed529d03a9f76141598a4038f3c51cbca828b1f3e9203a25dab91ee1ff31fee2bf2781d6171dc662f5aa1715c9d5296f8607c60')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ $ i cd Shapely-$pkgver && patch -p1 -i "$srcdir/load_dll_c.patch"
+ '
+)"
+
+# patch CARCH to always use i686 build directory during testing
+eval "$(
+ declare -f check | \
+ sed '
+ /.*py.test/s/\$CARCH/i686/
+ '
+)"