Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/python-shapely/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/python-shapely/PKGBUILD')
-rw-r--r--extra/python-shapely/PKGBUILD15
1 files changed, 15 insertions, 0 deletions
diff --git a/extra/python-shapely/PKGBUILD b/extra/python-shapely/PKGBUILD
new file mode 100644
index 00000000..c45e9935
--- /dev/null
+++ b/extra/python-shapely/PKGBUILD
@@ -0,0 +1,15 @@
+# Temporary hack for gcc14
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i CFLAGS="-Wno-incompatible-pointer-types $CFLAGS"
+ '
+)"
+
+# patch CARCH to always use i686 build directory during testing
+eval "$(
+ declare -f check | \
+ sed '
+ s/x86_64/i686/
+ '
+)"