Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/python-shapely/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/python-shapely/PKGBUILD')
-rw-r--r--extra/python-shapely/PKGBUILD16
1 files changed, 4 insertions, 12 deletions
diff --git a/extra/python-shapely/PKGBUILD b/extra/python-shapely/PKGBUILD
index 14ce07a9..c45e9935 100644
--- a/extra/python-shapely/PKGBUILD
+++ b/extra/python-shapely/PKGBUILD
@@ -1,16 +1,8 @@
-# temporary fix for:
-# - https://github.com/Toblerity/Shapely/pull/762
-#
-# which caused:
-# - https://community.ultimaker.com/topic/29721-archlinux32-cura-341/?_fromLogin=1#replyForm
-#
-source+=(load_dll_c.patch)
-sha512sums+=('6dee4823b76d5057beaed09e9ed529d03a9f76141598a4038f3c51cbca828b1f3e9203a25dab91ee1ff31fee2bf2781d6171dc662f5aa1715c9d5296f8607c60')
-
+# Temporary hack for gcc14
eval "$(
- declare -f prepare | \
+ declare -f build | \
sed '
- $ i cd Shapely-$pkgver && patch -p1 -i "$srcdir/load_dll_c.patch"
+ 3 i CFLAGS="-Wno-incompatible-pointer-types $CFLAGS"
'
)"
@@ -18,6 +10,6 @@ eval "$(
eval "$(
declare -f check | \
sed '
- /.*py.test/s/\$CARCH/i686/
+ s/x86_64/i686/
'
)"