Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/python-pip/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/python-pip/PKGBUILD')
-rw-r--r--extra/python-pip/PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/extra/python-pip/PKGBUILD b/extra/python-pip/PKGBUILD
index 77266044..794fb07d 100644
--- a/extra/python-pip/PKGBUILD
+++ b/extra/python-pip/PKGBUILD
@@ -1,8 +1,12 @@
-# no python-sphinx
-makedepends=(${makedepends[@]/python-sphinx-inline-tabs/})
-makedepends=(${makedepends[@]/python-sphinx-copybutton/})
-makedepends=(${makedepends[@]/python-sphinxcontrib-towncrier/})
-makedepends=(${makedepends[@]/python-sphinx/})
+# boostrapping python modules
+
+# no testing no test or optional dependencies
+unset check
+unset checkdepends
+unset optdepends
+
+# no documentation, breaking the cycle with python-spinx
+makedepends=(${makedepends[@]//python-sphinx*/})
eval "$(
declare -f build | \
sed '