Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/python-libnacl/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/python-libnacl/PKGBUILD')
-rw-r--r--extra/python-libnacl/PKGBUILD15
1 files changed, 15 insertions, 0 deletions
diff --git a/extra/python-libnacl/PKGBUILD b/extra/python-libnacl/PKGBUILD
new file mode 100644
index 00000000..6eda5b5e
--- /dev/null
+++ b/extra/python-libnacl/PKGBUILD
@@ -0,0 +1,15 @@
+# see https://bbs.archlinux32.org/viewtopic.php?pid=224
+# and https://github.com/saltstack/libnacl/issues/103
+
+eval "$(
+ {
+ declare -f prepare || \
+ printf 'prepare() {\n}\n'
+ } \
+ | sed '
+ $i sed -i '"'"' \
+ s/m, mlen,/m, ctypes.byref(mlen),/ \
+ '"'"' "libnacl-${pkgver}/libnacl/__init__.py" \
+ cp -r libnacl-$pkgver{,-py2}
+ '
+)"