Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/python-jaraco.context/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/python-jaraco.context/PKGBUILD')
-rw-r--r--extra/python-jaraco.context/PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/extra/python-jaraco.context/PKGBUILD b/extra/python-jaraco.context/PKGBUILD
new file mode 100644
index 00000000..b0d7bd85
--- /dev/null
+++ b/extra/python-jaraco.context/PKGBUILD
@@ -0,0 +1,18 @@
+# temporary to build python-build with python-bootstrap (breaking cycles)
+makedepends=(${makedepends[@]//python-build/})
+makedepends=(${makedepends[@]//python-installer/})
+makedepends=(${makedepends[@]//python-wheel/})
+makedepends+=('python-bootstrap')
+depends=(${depends[@]//python-jaraco.functools/})
+depends=(${depends[@]//python-jaraco.context/})
+depends=(${depends[@]//python-jaraco.context/})
+depends=(${depends[@]//python-autocommand/})
+depends=(${depends[@]//python-inflect/})
+unset checkdepends
+unset check
+eval "$(
+ declare -f build | \
+ sed '
+ s/python -m build -wn/python -m build -wn -x/g
+ '
+)"