Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/python-installer/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/python-installer/PKGBUILD')
-rw-r--r--extra/python-installer/PKGBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/extra/python-installer/PKGBUILD b/extra/python-installer/PKGBUILD
index 6dd1a147..b67bf28e 100644
--- a/extra/python-installer/PKGBUILD
+++ b/extra/python-installer/PKGBUILD
@@ -1,8 +1,12 @@
-# breaking the cycle with python-spinx
-makedepends=(${makedepends[@]//python-sphinx-furo})
-makedepends=(${makedepends[@]//python-sphinx-argparse})
-makedepends=(${makedepends[@]//python-sphinx})
-makedepends=(${makedepends[@]//python-myst-parser/})
+# boostrapping python modules
+
+# no testing no test or optional dependencies
+unset check
+unset checkdepends
+unset optdepends
+
+# no documentation, breaking the cycle with python-spinx
+makedepends=(${makedepends[@]//python-sphinx*/})
eval "$(
declare -f build | \
sed '
@@ -14,10 +18,3 @@ eval "$(
'
)"
-# temporary to build python-build with python-bootstrap (breaking cycles)
-makedepends=(${makedepends[@]//python-installer/})
-makedepends=(${makedepends[@]//python-build/})
-makedepends=(${makedepends[@]//python-flit-core/})
-makedepends+=('python-bootstrap')
-unset checkdepends
-unset check