Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/python-installer/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/python-installer/PKGBUILD')
-rw-r--r--extra/python-installer/PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/extra/python-installer/PKGBUILD b/extra/python-installer/PKGBUILD
new file mode 100644
index 00000000..b67bf28e
--- /dev/null
+++ b/extra/python-installer/PKGBUILD
@@ -0,0 +1,20 @@
+# boostrapping python modules
+
+# no testing no test or optional dependencies
+unset check
+unset checkdepends
+unset optdepends
+
+# no documentation, breaking the cycle with python-spinx
+makedepends=(${makedepends[@]//python-sphinx*/})
+eval "$(
+ declare -f build | \
+ sed '
+ /sphinx-build/d
+ '
+ declare -f package | \
+ sed '
+ /docs\/build\/html/d
+ '
+)"
+