Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/python-build/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/python-build/PKGBUILD')
-rw-r--r--extra/python-build/PKGBUILD32
1 files changed, 13 insertions, 19 deletions
diff --git a/extra/python-build/PKGBUILD b/extra/python-build/PKGBUILD
index 125d6731..1ebceb08 100644
--- a/extra/python-build/PKGBUILD
+++ b/extra/python-build/PKGBUILD
@@ -1,25 +1,19 @@
-# disable documentation (needs sphinx, sphinx-furo)
-# python-sphinx-furo needs npm, which is broken on archlinux32
-# most likely since years..
-makedepends=(${makedepends[@]//python-sphinx-furo/})
-makedepends=(${makedepends[@]//python-sphinx-argparse-cli/})
-makedepends=(${makedepends[@]//python-sphinx-autodoc-typehints/})
-makedepends=(${makedepends[@]//python-sphinx/})
+# boostrapping python modules
+
+# no testing no test or optional dependencies
+unset check
+unset checkdepends
+unset optdepends
+
+# no documentation, breaking the cycle with python-spinx
+makedepends=(${makedepends[@]//python-sphinx*/})
eval "$(
- declare -f build | \
+ declare -f build | \
sed '
- /.*sphinx-build.*/d
+ /sphinx-build/d
'
- declare -f package | \
+ declare -f package | \
sed '
- /.*\/share\/doc.*/d
+ \@/doc/@d
'
)"
-
-# temporary to build python-build with python-bootstrap (breaking cycles)
-makedepends=(${makedepends[@]//python-installer/})
-makedepends=(${makedepends[@]//python-build/})
-makedepends=(${makedepends[@]//python-flit-core/})
-makedepends+=('python-bootstrap')
-unset checkdepends
-unset check