Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/python-build/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/python-build/PKGBUILD')
-rw-r--r--extra/python-build/PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/extra/python-build/PKGBUILD b/extra/python-build/PKGBUILD
new file mode 100644
index 00000000..1ebceb08
--- /dev/null
+++ b/extra/python-build/PKGBUILD
@@ -0,0 +1,19 @@
+# boostrapping python modules
+
+# no testing no test or optional dependencies
+unset check
+unset checkdepends
+unset optdepends
+
+# no documentation, breaking the cycle with python-spinx
+makedepends=(${makedepends[@]//python-sphinx*/})
+eval "$(
+ declare -f build | \
+ sed '
+ /sphinx-build/d
+ '
+ declare -f package | \
+ sed '
+ \@/doc/@d
+ '
+)"