Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/protobuf/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/protobuf/PKGBUILD')
-rw-r--r--extra/protobuf/PKGBUILD14
1 files changed, 14 insertions, 0 deletions
diff --git a/extra/protobuf/PKGBUILD b/extra/protobuf/PKGBUILD
new file mode 100644
index 00000000..ca6fdb6b
--- /dev/null
+++ b/extra/protobuf/PKGBUILD
@@ -0,0 +1,14 @@
+# ignore failing tests
+eval "$(
+ declare -f check | \
+ sed '
+ s@\(ctest .*\);@\1 || true;@
+ '
+)"
+
+# no LTO on i486
+if [ "$CARCH" = 'i486' ]; then
+ sed -i '
+ 1i options=(!lto)
+ ' PKGBUILD
+fi