Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/protobuf/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/protobuf/PKGBUILD')
-rw-r--r--extra/protobuf/PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/extra/protobuf/PKGBUILD b/extra/protobuf/PKGBUILD
index 2e13a8c5..ca6fdb6b 100644
--- a/extra/protobuf/PKGBUILD
+++ b/extra/protobuf/PKGBUILD
@@ -2,8 +2,13 @@
eval "$(
declare -f check | \
sed '
- s@make check@make check || true@
- s@python setup.py test@python setup.py test || true@
+ s@\(ctest .*\);@\1 || true;@
'
-)
-"
+)"
+
+# no LTO on i486
+if [ "$CARCH" = 'i486' ]; then
+ sed -i '
+ 1i options=(!lto)
+ ' PKGBUILD
+fi