Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/postfix/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/postfix/PKGBUILD')
-rw-r--r--extra/postfix/PKGBUILD27
1 files changed, 24 insertions, 3 deletions
diff --git a/extra/postfix/PKGBUILD b/extra/postfix/PKGBUILD
index a6e73395..79e1e48f 100644
--- a/extra/postfix/PKGBUILD
+++ b/extra/postfix/PKGBUILD
@@ -1,11 +1,32 @@
# do not make postfix depend on a micro-optimized Mysql (for i486)
if [ "${CARCH}" = "i486" ]; then
- depends=(${depends[@]//mariadb-libs/})
+ makedepends=(${makedepends[@]//mariadb-libs/})
eval "$(
declare -f build | \
sed '
- s|-DHAS_MYSQL -I/usr/include/mysql||g
- s|-lmysqlclient||g
+ s|'-DHAS_MYSQL' '-I/usr/include/mysql'||g
'
)"
+
+ source+=(postfix-3.5.10-no-mysql.patch)
+ sha512sums+=('48598226c220caa2b58be25727f3f0d978beef5c6f42f4dfd8e97a32125739d3b15ef8328c17f9ab8b0d659c13ae6902afb5c5d2257cabe02e9f5efa8ea7d4f8')
+ b2sums+=('df89a8bdf214af3253c9967749c36ae6cd48cb1fee1a38a349180599ad59b700764e83c6b19cba49866ffbe6d34d0c2f710affa240e0e89fec5256fc0ede9f0f')
+
+ eval "$(
+ declare -f prepare | \
+ sed '
+ /main_defaults.patch/a patch -p1 -i ${srcdir}/postfix-3.5.10-no-mysql.patch
+ '
+ declare -f package_postfix | \
+ sed '
+ /for _feature/s/,mysql//g
+ s/LD_LIBRARY_PATH/touch lib\/postfix-mysql.so; LD_LIBRARY_PATH/
+ '
+ declare -f package_postfix-mysql | \
+ sed '
+ 3 i if false; then
+ $ i fi
+ '
+ )
+ "
fi