Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/pacman-contrib
diff options
context:
space:
mode:
Diffstat (limited to 'extra/pacman-contrib')
-rw-r--r--extra/pacman-contrib/PKGBUILD9
-rw-r--r--extra/pacman-contrib/rankmirror.sh.diff16
2 files changed, 25 insertions, 0 deletions
diff --git a/extra/pacman-contrib/PKGBUILD b/extra/pacman-contrib/PKGBUILD
new file mode 100644
index 00000000..5e28a760
--- /dev/null
+++ b/extra/pacman-contrib/PKGBUILD
@@ -0,0 +1,9 @@
+source+=('rankmirror.sh.diff')
+b2sums+=('170770a9fc250fd917c409289f6bf06f889265d20324f50083d0a97e8772dc971c302c8a81a857b433015feb8d3fec6cf48231fdc57fc320d7d3f18aa0aa6ca7')
+
+eval "$(
+ declare -f prepare \
+ | sed '
+ $ i patch -p1 -i "${srcdir}/rankmirror.sh.diff"
+ '
+)"
diff --git a/extra/pacman-contrib/rankmirror.sh.diff b/extra/pacman-contrib/rankmirror.sh.diff
new file mode 100644
index 00000000..c7ea00a1
--- /dev/null
+++ b/extra/pacman-contrib/rankmirror.sh.diff
@@ -0,0 +1,16 @@
+diff --git a/src/rankmirrors.sh.in b/src/rankmirrors.sh.in
+index 08f7e28..8f9143f 100644
+--- a/src/rankmirrors.sh.in
++++ b/src/rankmirrors.sh.in
+@@ -79,10 +79,8 @@ getfetchurl() {
+ local replacedurl="${strippedurl//'$arch'/$ARCH}"
+ if [[ ! $TARGETREPO ]]; then
+ replacedurl="${replacedurl//'$repo'/core}"
+- local tmp="${replacedurl%/*}"
+- tmp="${tmp%/*}"
+
+- local reponame="${tmp##*/}"
++ local reponame="${replacedurl##*/}"
+ else
+ replacedurl="${replacedurl//'$repo'/$TARGETREPO}"
+ local reponame="$TARGETREPO"