Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/opensubdiv/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/opensubdiv/PKGBUILD')
-rw-r--r--extra/opensubdiv/PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/extra/opensubdiv/PKGBUILD b/extra/opensubdiv/PKGBUILD
new file mode 100644
index 00000000..7ee1e57b
--- /dev/null
+++ b/extra/opensubdiv/PKGBUILD
@@ -0,0 +1,19 @@
+# no CUDA
+makedepends=(
+ ${makedepends[@]/cuda/}
+)
+pkgdesc+=", without CUDA support"
+
+eval "$(
+ declare -f build | \
+ sed '
+ s/cmake /cmake -DNO_CUDA=ON /
+ '
+)"
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ /cuda.*patch/d
+ '
+)"