Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/openmpi/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/openmpi/PKGBUILD')
-rw-r--r--extra/openmpi/PKGBUILD44
1 files changed, 0 insertions, 44 deletions
diff --git a/extra/openmpi/PKGBUILD b/extra/openmpi/PKGBUILD
deleted file mode 100644
index a932d3f0..00000000
--- a/extra/openmpi/PKGBUILD
+++ /dev/null
@@ -1,44 +0,0 @@
-# no CUDA
-makedepends=(${makedepends[@]//cuda/})
-makedepends=(${makedepends[@]//nvidia-utils/})
-eval "$(
- declare -f build | \
- sed '
- /local configure_options.*/ a \
- configure_options=(${configure_options[@]/--with-cuda=.*/--without-cuda})
- '
-)"
-
-# PRRTE warns us about not building on 32-bit, so remove it
-makedepends=(${makedepends[@]//prtte/})
-eval "$(
- declare -f build | \
- sed '
- /local configure_options.*/ a \
- configure_options=(${configure_options[@]/--with-prrte=external/--without-prrte})
- '
-)"
-eval "$(
- declare -f package_openmpi | \
- sed '
- /depends.*/ a \
- depends=(${depends[@]//prrte/})
- '
-)"
-
-# AMD stuff requires a special LLVM and clang, doesn't build currently
-# (whoever wants to fix that is welcome)
-makedepends=(${makedepends[@]//hip-runtime-amd/})
-
-# openucc doesn't build
-makedepends=(${makedepends[@]//openucc/})
-
-# openucx requires cuda and rocm-language-runtime
-makedepends=(${makedepends[@]//openucx/})
-eval "$(
- declare -f package_openmpi | \
- sed '
- /depends.*/ a \
- depends=(${depends[@]//openucx/})
- '
-)"