Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/opencolorio/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/opencolorio/PKGBUILD')
-rw-r--r--extra/opencolorio/PKGBUILD14
1 files changed, 2 insertions, 12 deletions
diff --git a/extra/opencolorio/PKGBUILD b/extra/opencolorio/PKGBUILD
index 7d8f94cf..2bed32b2 100644
--- a/extra/opencolorio/PKGBUILD
+++ b/extra/opencolorio/PKGBUILD
@@ -1,16 +1,6 @@
-# Disable SSE2 in the cmake probing (we cannot set it from outside, so
-# cross-compilation or building in a chrooted environment fails)
-source+=('OpenColorIO-2.1.1-no-sse2.patch')
-sha512sums+=('8055b90d387e2cd674a25344b520d093ef8f761f294a77c71694f7ba93806a58350140b7e373e91432d555def5addd35fad4aca59518aab12b56c5b6106c4352')
+# Disable SSE2
if [ "$CARCH" = 'i686' -o "$CARCH" = 'i486' ]; then
eval "$(
- {
- declare -f prepare || \
- printf 'prepare() {\n}\n'
- } \
- | sed '
- $i cd "$srcdir/OpenColorIO-$pkgver" \
- patch -Np1 -i "$srcdir/OpenColorIO-2.1.1-no-sse2.patch"
- '
+ declare -f build | sed 's/cmake /cmake -DOCIO_USE_SIMD=OFF /'
)"
fi