Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/meson/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/meson/PKGBUILD')
-rw-r--r--extra/meson/PKGBUILD26
1 files changed, 25 insertions, 1 deletions
diff --git a/extra/meson/PKGBUILD b/extra/meson/PKGBUILD
index a2d42e6e..5e49a967 100644
--- a/extra/meson/PKGBUILD
+++ b/extra/meson/PKGBUILD
@@ -1,3 +1,27 @@
-# checks fail in various ways (also upstream)
+# we have no 32-bit cuda support
+checkdepends=(${checkdepends[@]//cuda/})
+
+# no rust on i486
+checkdepends=(${checkdepends[@]//rust-bindgen/})
+checkdepends=(${checkdepends[@]//rust/})
+checkdepends_i686+=('rust')
+checkdepends_i686+=('rust-bindgen')
+
+# D compiler broken on i486
+checkdepends=(${checkdepends[@]//ldc/})
+checkdepends_i686+=('ldc')
+
+checkdepends_pentium4=("${checkdepends_i686[@]}")
+
+# still far too many tests fail, ignoring for now
unset check
unset checkdepends
+
+# fail if upstream changes arch-meson
+# we patch a version of arch-meson reading CARCH (later maybe LTOFLAGS)
+# to find out whether it should add blto to the arch flags
+for ((i=0; i<${#b2sums[@]}; i++)); do
+ if [ "${b2sums[${i}]}" = '70f042a7603d1139f6cef33aec028da087cacabe278fd47375e1b2315befbfde1c0501ad1ecc63d04d31b232a04f08c735d61ce59d7244521f3d270e417fb5af' ]; then
+ b2sums[${i}]='09f3035aaff3fe8ac8e57a6e718acd654c04604500abb897a4d6e3946c9e4d9db6a257b5cd3d27007bfcfd4799a2b52d8eaab38ecda16f8af69848ed3b8ac7ff'
+ fi
+done