Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/mesa
diff options
context:
space:
mode:
Diffstat (limited to 'extra/mesa')
-rw-r--r--extra/mesa/PKGBUILD29
1 files changed, 18 insertions, 11 deletions
diff --git a/extra/mesa/PKGBUILD b/extra/mesa/PKGBUILD
index fee4b17d..635939e1 100644
--- a/extra/mesa/PKGBUILD
+++ b/extra/mesa/PKGBUILD
@@ -23,17 +23,6 @@ if [ "$CARCH" == 'i486' ]; then
)"
fi
-# disable libclc
-makedepends=(${makedepends[@]//libclc/})
-eval "$(
- declare -f package_opencl-mesa \
- | sed '
- /depends=/ {
- s/'"'"'libclc'"'"'//
- }
- '
-)"
-
# See https://bugs.freedesktop.org/show_bug.cgi?id=93089
# do not build/package vulkan on i486
# do not build i915,i965 on i486
@@ -70,3 +59,21 @@ if [ "$CARCH" = 'i486' ]; then
'
)"
fi
+
+# disable rust stuff on i486 (disable for i686/pentium4 too for now as
+# rust is broken there and cannot be rebuilt)
+#if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/-D gallium-rusticl=true/-D gallium-rusticl=false/g
+ s/-D rust_std=\S\+//
+ '
+ declare -f package_vulkan-virtio | \
+ sed '
+ /.*virtio_icd.*json.*/d
+ '
+ )"
+ makedepends=(${makedepends[@]//rust-bindgen/})
+ makedepends=(${makedepends[@]//rust/})
+#fi