Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/mesa
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2023-03-03 09:03:47 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2023-03-03 09:03:47 +0100
commit5d1a76cbcb3285d1e886287e55a1ee81ab997e63 (patch)
treef6bef73dbc738a31a8ea89eda28c7d46807d0f15 /extra/mesa
parent7f2943784cd4eb44c94ac037418c666aaae09719 (diff)
extra/mesa: readded libclc and removed rust stuff (for now on i686/pentium4, forever likely on i486)
Diffstat (limited to 'extra/mesa')
-rw-r--r--extra/mesa/PKGBUILD29
1 files changed, 18 insertions, 11 deletions
diff --git a/extra/mesa/PKGBUILD b/extra/mesa/PKGBUILD
index fee4b17d..635939e1 100644
--- a/extra/mesa/PKGBUILD
+++ b/extra/mesa/PKGBUILD
@@ -23,17 +23,6 @@ if [ "$CARCH" == 'i486' ]; then
)"
fi
-# disable libclc
-makedepends=(${makedepends[@]//libclc/})
-eval "$(
- declare -f package_opencl-mesa \
- | sed '
- /depends=/ {
- s/'"'"'libclc'"'"'//
- }
- '
-)"
-
# See https://bugs.freedesktop.org/show_bug.cgi?id=93089
# do not build/package vulkan on i486
# do not build i915,i965 on i486
@@ -70,3 +59,21 @@ if [ "$CARCH" = 'i486' ]; then
'
)"
fi
+
+# disable rust stuff on i486 (disable for i686/pentium4 too for now as
+# rust is broken there and cannot be rebuilt)
+#if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/-D gallium-rusticl=true/-D gallium-rusticl=false/g
+ s/-D rust_std=\S\+//
+ '
+ declare -f package_vulkan-virtio | \
+ sed '
+ /.*virtio_icd.*json.*/d
+ '
+ )"
+ makedepends=(${makedepends[@]//rust-bindgen/})
+ makedepends=(${makedepends[@]//rust/})
+#fi