Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/mesa/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/mesa/PKGBUILD')
-rw-r--r--extra/mesa/PKGBUILD14
1 files changed, 14 insertions, 0 deletions
diff --git a/extra/mesa/PKGBUILD b/extra/mesa/PKGBUILD
new file mode 100644
index 00000000..380cad2f
--- /dev/null
+++ b/extra/mesa/PKGBUILD
@@ -0,0 +1,14 @@
+# disable openswf as it requires AVX, makes no sense with old CPUs
+# disable every new software rasterizer and take the old ones
+# see also FS32#39
+eval "$(
+ declare -f build | \
+ sed '
+ /arch-meson/s/\(gallium-drivers=.*\),swrast,swr/\1,swrast/
+ /arch-meson/s/\(-D swr-arches=\)avx,avx2/\1/
+ '
+ declare -f package_mesa | \
+ sed '
+ s@_install fakeinstall/usr/lib/libswrAVX.*@#\0@g
+ '
+)"