Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/linux-zen/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/linux-zen/PKGBUILD')
-rw-r--r--extra/linux-zen/PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/extra/linux-zen/PKGBUILD b/extra/linux-zen/PKGBUILD
index 41ef2d72..f6f34664 100644
--- a/extra/linux-zen/PKGBUILD
+++ b/extra/linux-zen/PKGBUILD
@@ -20,11 +20,19 @@ eval "$(
)"
_get_gcc_version_from_config() {
- sed '
- s/^CONFIG_CC_VERSION_TEXT="gcc (GCC) \([0-9.]\+\)"$/\1/
- t
- d
- ' "$srcdir/$_srcname/.config"
+ if [ -z "$srcdir" ]; then
+ gcc --version \
+ | sed '
+ s@^.* @@
+ 1!d
+ '
+ else
+ sed '
+ s/^CONFIG_CC_VERSION_TEXT="gcc (GCC) \([0-9.]\+\)"$/\1/
+ t
+ d
+ ' "$srcdir/$_srcname/.config"
+ fi
}
# use our tarballer instead of cloning from git