Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/linux-pae/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/linux-pae/PKGBUILD')
-rw-r--r--extra/linux-pae/PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/extra/linux-pae/PKGBUILD b/extra/linux-pae/PKGBUILD
index 00448631..5da48508 100644
--- a/extra/linux-pae/PKGBUILD
+++ b/extra/linux-pae/PKGBUILD
@@ -219,6 +219,16 @@ done
# vim:set ts=8 sts=2 sw=2 et:
+# avoid using zstd compression in ultra mode (exhausts virtual memory)
+source+=('no-ultra-zstd.patch')
+sha256sums+=('d32270be5fd9c3e3ba50f3aef33f6cfcb85be0c8216f03b777287cc621fdff28')
+eval "$(
+ declare -f prepare | \
+ sed '
+ /cd/ a patch -Np1 -i $srcdir/no-ultra-zstd.patch
+ '
+)"
+
# https://bbs.archlinux32.org/viewtopic.php?pid=9109#p9109
# avoid "sleepy" VIA C7 CPUs (and possibly others)
source+=('acpi-c3.patch')