Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/linux-olpc-xo1/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/linux-olpc-xo1/PKGBUILD')
-rw-r--r--extra/linux-olpc-xo1/PKGBUILD49
1 files changed, 37 insertions, 12 deletions
diff --git a/extra/linux-olpc-xo1/PKGBUILD b/extra/linux-olpc-xo1/PKGBUILD
index ff1787f7..f3e539e1 100644
--- a/extra/linux-olpc-xo1/PKGBUILD
+++ b/extra/linux-olpc-xo1/PKGBUILD
@@ -2,11 +2,11 @@
MODEL=olpc-xo1
pkgbase=linux-${MODEL}
-pkgver='5.7.12.arch1'
+pkgver='6.4.2.arch1'
pkgrel='1'
pkgdesc='Linux for OLPC XO-1'
_srctag=v${pkgver%.*}-${pkgver##*.}
-url="https://git.archlinux.org/linux.git/log/?h=$_srctag"
+url="https://github.com/archlinux/linux/log/?h=$_srctag"
arch=(i486 i686 pentium4 x86_64)
license=(GPL2)
makedepends=(
@@ -17,18 +17,18 @@ makedepends=(
options=('!strip')
_srcname=archlinux-linux
source=(
- "$_srcname::git+https://git.archlinux.org/linux.git?signed#tag=$_srctag"
+ "$_srcname::git+https://github.com/archlinux/linux?signed#tag=$_srctag"
config.${MODEL} # the main kernel config file
- sphinx-workaround.patch
+ 'no-ultra-zstd.patch'
)
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
'A2FF3A36AAA56654109064AB19802F8B0D70FC30' # Jan Alexander Steffens (heftig)
)
-sha256sums=('2d6a5cbdb08d5fc79288c987733b0e910cdebe2f5e60070056c03290d09b867d'
- '18730a94777487843be91aff97ca7553e6a666219c810fc570a920f877877c1d'
- '8cb21e0b3411327b627a9dd15b8eb773295a0d2782b1a41b2a8839d1b2f5778c')
+sha256sums=('dad0ade4d0310e8544dee6d6dd84a3e3ae1a54cea24ee506fc5a53f6a8e9d2cd'
+ '5984463c308416132ee6821eea3e760b83ebf7337ee8bad26f6e487c3a19964f'
+ 'd32270be5fd9c3e3ba50f3aef33f6cfcb85be0c8216f03b777287cc621fdff28')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
@@ -53,7 +53,10 @@ prepare() {
echo "Setting config..."
cp ../config.${MODEL} .config
- make olddefconfig
+ # make olddefconfig
+
+ # rewrite configuration
+ yes "" | make config >/dev/null
make -s kernelrelease > version
echo "Prepared $pkgbase version $(<version)"
@@ -162,6 +165,26 @@ _package-headers() {
echo "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"
+ depends+=(gcc-libs=$(_get_gcc_version_from_config))
+}
+
+_get_gcc_version_from_config() {
+ if [ -z "$srcdir" ]; then
+ gcc --version \
+ | sed '
+ s@^.* @@
+ 1!d
+ '
+ else
+ for _config_file in "$srcdir/$_srcname/.config" "$srcdir/config.${MODEL}" "${srcdir%/*}/config.${MODEL}"; do
+ [ -f "$_config_file" ] && break
+ done
+ sed '
+ s/^CONFIG_CC_VERSION_TEXT="gcc (GCC) \([0-9.]\+\)"$/\1/
+ t
+ d
+ ' "$_config_file"
+ fi
}
_package-docs() {
@@ -195,10 +218,12 @@ done
for ((i=0; i<${#source[@]}; i++)); do
infos=$(
printf '%s\n' "${source[${i}]}" | \
- sed -n '
- s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=\S\+\)$@\3 \2 \4 \5 \6@
- T
- p
+ sed '
+ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=[^?]\+\)$@\3 \2 \4 \5 \6@
+ t
+ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)#\(\(tag\|commit\)=[^?]\+\)\(?signed\)\?$@\3 \2 \4 \7 \5@
+ t
+ d
'
)
if [ -n "${infos}" ]; then