Send patches - preferably formatted by git format-patch - to patches at archlinux32 dot org.
summaryrefslogtreecommitdiff
path: root/extra/linux-galileo-gen2/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'extra/linux-galileo-gen2/PKGBUILD')
-rw-r--r--extra/linux-galileo-gen2/PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/extra/linux-galileo-gen2/PKGBUILD b/extra/linux-galileo-gen2/PKGBUILD
index 0cb05e97..c7885561 100644
--- a/extra/linux-galileo-gen2/PKGBUILD
+++ b/extra/linux-galileo-gen2/PKGBUILD
@@ -94,11 +94,19 @@ _package() {
}
_get_gcc_version_from_config() {
- sed '
- s/^CONFIG_CC_VERSION_TEXT="gcc (GCC) \([0-9.]\+\)"$/\1/
- t
- d
- ' "$srcdir/$_srcname/.config"
+ if [ -z "$srcdir" ]; then
+ gcc --version \
+ | sed '
+ s@^.* @@
+ 1!d
+ '
+ else
+ sed '
+ s/^CONFIG_CC_VERSION_TEXT="gcc (GCC) \([0-9.]\+\)"$/\1/
+ t
+ d
+ ' "$srcdir/$_srcname/.config"
+ fi
}
_package-headers() {